We are currently experiencing issues with space Identity subsystem.
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Sep 03, 2021 - 10:43 UTC
Investigating
We are currently investigating this issue.
Posted Sep 03, 2021 - 10:27 UTC
This incident affected: Components and Supply Chain (US-East), Design Review & Sharing on Web (US-East), Projects Storage (US-East), MCAD CoDesigner (US-East), Releases and Manufacturing (US-East), and User Identity (US-East).