Libraries Storage experiencing some problems
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Oct 20, 2021 - 08:58 UTC
Investigating
We are currently investigating this issue.
Posted Oct 20, 2021 - 08:46 UTC
This incident affected: Releases and Manufacturing (Europe), Design Review & Sharing on Web (Europe), Components and Supply Chain (Europe), and MCAD CoDesigner (Europe).