Mechanical CAD collaboration is not working
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 16:22 UTC
Investigating
We are currently investigating this issue.
Posted Nov 17, 2021 - 14:50 UTC
This incident affected: MCAD CoDesigner (Europe).