Weekly Maintenance prolongated
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Sep 25, 2022 - 13:27 UTC
Monitoring
Weekly Maintenance needs to be prolongated
Posted Sep 25, 2022 - 11:57 UTC
This incident affected: Projects Storage (Europe, Asia, US-East, US-West), Releases and Manufacturing (Europe, Asia, US-East, US-West), Design Review & Sharing on Web (Europe, Asia, US-East, US-West), Components and Supply Chain (Europe, Asia, US-East, US-West), MCAD CoDesigner (Europe, Asia, US-East, US-West), and User Identity (Europe, Asia, US-East, US-West).