Libraries Storage experiencing some problems
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 12:51 UTC
Update
We are continuing to investigate this issue.
Posted Jun 20, 2022 - 12:34 UTC
Investigating
We are currently investigating this issue.
Posted Jun 20, 2022 - 12:20 UTC
This incident affected: Releases and Manufacturing (Europe, Asia, US-East, US-West), MCAD CoDesigner (Europe, Asia, US-East, US-West), Design Review & Sharing on Web (Europe, Asia, US-East, US-West), and Components and Supply Chain (Europe, Asia, US-East, US-West).