Libraries Storage experiencing some problems
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Jul 09, 2021 - 09:02 UTC
Investigating
We are currently investigating this issue.
Posted Jul 09, 2021 - 08:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2021 - 08:32 UTC
Investigating
We are currently investigating this issue.
Posted Jul 09, 2021 - 06:19 UTC
This incident affected: Projects Storage (US-East), Releases and Manufacturing (US-East), Design Review & Sharing on Web (US-East), MCAD CoDesigner (US-East), and Components and Supply Chain (US-East).