Incident with Projects Storage, Releases and Manufacturing, Design Review & Sharing on Web, MCAD CoDesigner, User Identity

Incident Report for Altium 365

Resolved

The incident has been resolved.
Posted Apr 12, 2025 - 13:22 UTC

Investigating

We are currently investigating this issue.
Posted Apr 12, 2025 - 13:05 UTC
This incident affected: Design Review & Sharing on Web (US-East).