Incident with Projects Storage, Releases and Manufacturing, Design Review & Sharing on Web, Components and Supply Chain, MCAD CoDesigner, User Identity

Incident Report for Altium 365

Resolved

Incident resolved - We are no longer observing database overload issues affecting a subset of customers in the "us-east-1" region.
Posted Aug 04, 2025 - 16:41 UTC

Monitoring

The issue has been mitigated.
Some of our customers in the "us-east-1" region may have experienced errors related to a brief database overload.
We are continuing to monitor the situation.
Posted Aug 04, 2025 - 16:32 UTC

Update

We are currently investigating issues we’re experiencing in the US East (N. Virginia) region.
Posted Aug 04, 2025 - 16:23 UTC

Investigating

We are currently investigating this issue.
Posted Aug 04, 2025 - 16:20 UTC
This incident affected: Projects Storage (US-East), Releases and Manufacturing (US-East), Design Review & Sharing on Web (US-East), Components and Supply Chain (US-East), and MCAD CoDesigner (US-East).