Incident with Projects Storage, Releases and Manufacturing, Design Review & Sharing on Web, Components and Supply Chain, MCAD CoDesigner, User Identity
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Nov 28, 2023 - 00:36 UTC
Investigating
We are currently investigating this issue.
Posted Nov 28, 2023 - 00:11 UTC
This incident affected: Projects Storage (Asia), Releases and Manufacturing (Asia), MCAD CoDesigner (Asia), and Components and Supply Chain (Asia).