Major database issue EU region
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Sep 23, 2021 - 11:17 UTC
Investigating
We are currently investigating this issue.
Posted Sep 23, 2021 - 11:11 UTC
This incident affected: Design Review & Sharing on Web (Europe), User Identity (Europe), Projects Storage (Europe), MCAD CoDesigner (Europe), Components and Supply Chain (Europe), and Releases and Manufacturing (Europe).