Components and Supply Chain Outage

Incident Report for Altium 365

Resolved

Incident with Components and Supply Chain - Resolved.
Posted Mar 30, 2026 - 08:54 UTC

Update

Incident with Components and Supply Chain - incident mitigated - Monitoring
Posted Mar 30, 2026 - 08:53 UTC

Monitoring

The root cause has been fixed, we're monitoring the services state
Posted Mar 30, 2026 - 08:39 UTC

Identified

Incident with Components and Supply Chain - mitigation in progress. A365 services affected by Octopart services not available.
Posted Mar 30, 2026 - 07:25 UTC

Update

We are continuing to investigate this issue.
Posted Mar 30, 2026 - 07:23 UTC

Investigating

We are currently investigating this issue.
Posted Mar 30, 2026 - 06:00 UTC
This incident affected: Components and Supply Chain (Europe, Asia, US-East, US-West).