Incident with Projects Storage, Releases and Manufacturing, Design Review & Sharing on Web, Components and Supply Chain, MCAD CoDesigner, User Identity

Incident Report for Altium 365

Resolved

We identified and fixed the issue that was causing performance degradation.
We apologize for the inconvenience and appreciate your patience.
Posted Nov 03, 2025 - 22:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2025 - 21:04 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 03, 2025 - 20:54 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 03, 2025 - 20:09 UTC

Identified

The team has identified the issue and is working on optimization to restore normal performance.
Posted Nov 03, 2025 - 19:08 UTC

Investigating

We are currently investigating this issue.
Posted Nov 03, 2025 - 18:56 UTC
This incident affected: Releases and Manufacturing (US-East) and Design Review & Sharing on Web (US-East).