Incident with Design Review & Sharing on Web
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Sep 12, 2022 - 21:43 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 12, 2022 - 20:36 UTC
Investigating
We are currently investigating this issue.
Posted Sep 12, 2022 - 20:33 UTC
This incident affected: Design Review & Sharing on Web (Europe).