Supply chain might be inaccessible

Incident Report for Altium 365

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 10:03 UTC

Identified

Our team is working on resolving the issue.
Posted Jul 20, 2026 - 09:54 UTC
This incident affected: Components and Supply Chain (Europe, Asia, US-East, US-West) and Projects Storage (US-West).