Calculations not working in Requirements portal in Europe

Incident Report for Altium 365

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 12:39 UTC

Update

We are continuing to investigate this issue.
Posted Mar 05, 2025 - 12:11 UTC

Investigating

We are currently investigating this issue.
Posted Mar 05, 2025 - 12:08 UTC
This incident affected: Design Review & Sharing on Web (Europe).