During the recent update, an unhealthy instance was introduced by AWS and subsequently terminated. Due to our reservation setup, this resulted in only a partial outage.
Posted Mar 19, 2025 - 18:00 UTC
Resolved
This incident has been resolved.
Posted Mar 19, 2025 - 17:36 UTC
Update
We found the issue and are working on mitigation.
Posted Mar 19, 2025 - 16:42 UTC
Investigating
We are currently investigating this issue.
Posted Mar 19, 2025 - 16:33 UTC
This incident affected: Components and Supply Chain (US-West).