We are currently experiencing issues with Identity subsystem. Multiple services could be impacted, including login from desktop applications and on-demand licensing.
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Sep 21, 2021 - 18:01 UTC
Update
We are continuing to investigate this issue.
Posted Sep 21, 2021 - 18:00 UTC
Investigating
We are currently investigating this issue.
Posted Sep 21, 2021 - 17:37 UTC
This incident affected: Design Review & Sharing on Web (Europe, Asia, US-East, US-West), User Identity (Europe, Asia, US-East, US-West), Projects Storage (Europe, Asia, US-East, US-West), MCAD CoDesigner (Europe, Asia, US-East, US-West), Components and Supply Chain (Europe, Asia, US-East, US-West), and Releases and Manufacturing (Europe, Asia, US-East, US-West).