We are currently experiencing issues with Identity subsystem. Multiple services could be impacted, including login from desktop applications and on-demand licensing.
Incident Report for Altium 365
Resolved
This incident has been resolved.
Posted Jun 04, 2021 - 16:27 UTC
Investigating
We are currently investigating this issue.
Posted Jun 04, 2021 - 16:24 UTC
This incident affected: Projects Storage (Europe, Asia, US-East, US-West), Releases and Manufacturing (Europe, Asia, US-East, US-West), Design Review & Sharing on Web (Europe, Asia, US-East, US-West), Components and Supply Chain (Europe, Asia, US-East, US-West), MCAD CoDesigner (Europe, Asia, US-East, US-West), and User Identity (Europe, Asia, US-East, US-West).