We are experiencing services performance degradation
Incident Report for Altium 365
Resolved
Monitoring Period finished , Issue marked as resolved.
Posted May 09, 2024 - 15:27 UTC
Monitoring
Issue resolved after deployments of fix. Monitoring stability of services.
Posted May 09, 2024 - 15:02 UTC
Update
Fix for Issue connected with session processing for Admin Processes and Process related Tasks in progress.

To mitigate please log off and log in to A365.
Posted May 09, 2024 - 10:53 UTC
Identified
Issue connected with session processing for Admin Processes and Process related Tasks was identified.

To mitigate please log off and log in to A365.
Posted May 09, 2024 - 10:07 UTC
Investigating
Our monitoring system detected issues with Admin Processes and Process related Tasks.
Investigation of core of an issue is currently in progress.

To mitigate please log off and log in to A365.
Posted May 09, 2024 - 09:42 UTC
This incident affected: Projects Storage (Europe) and Components and Supply Chain (Europe).